Ask questions and learn!

iOS 13 and LeadNAV

I fully understand iOS 13 is still in beta.
I'm just throwing out a couple of issues I have notice.

1. Maps completely disappear when zoom lever is 8+.
2. When pressing the share button, the app crashes.

Comments

  • Damian_offthegridDamian_offthegrid Posts: 638Administrator, Moderator admin
    We are currently not experiencing any of the bugs you are pointing out.

    Please provide us with more info.

    What device is this on?

    What specific beta version number?

    Did you update last week to the latest LEADNAV 5.10 (9) update?

    1) zoom level currently is not an issue. Are you online (cell/WiFi)? Or are you offline? If so is this on map imagery you prepped and saved down past 8 zoom? What map type?

    If I had to guess you are offline and did not save and store that map type before going offline/off the grid.

    2) testing share we are not seeing any bugs. Can you provide more info or a screen recording of the problem you are seeing. How and what are you sharing?
  • bjarne_simonsenbjarne_simonsen Posts: 2Member
    edited July 16
    I have the same problem on iOS 13 beta 2.
    No satellite maps at all.
    Need to zoom out to zoom7 - 100 km. to get the satellite map.
    Running latest version of LeadNav.
  • bjarne_simonsenbjarne_simonsen Posts: 2Member
    Need to zoom out to zoom7 - 100 km. to get the satellite map.
  • Damian_offthegridDamian_offthegrid Posts: 638Administrator, Moderator admin
    As mentioned can you confirm what device you are on, what version number of LEADNAV (in settings > support), what specific map type you are talking about, what subscription are you running (Advanced or Pro), are you on cellular or WiFi data when trying to view or are you running that specific map type prepped and saved for offline use?

    Also assume you have a solid understanding of LEADNAV functionality but can you confirm you’ve watched and completed the LEADNAV Lvl 1 online course videos?

    From there we can dissect the issue you are having as this is unique as there have been no other reports of this to go off of.
  • OneFast440OneFast440 Posts: 7Member
    What device is this on?
    Both iPhone XS Plus and iPad Pro 11"

    What specific beta version number?
    It has been on all iOS 13 developer betas.

    Did you update last week to the latest LEADNAV 5.10 (9) update?
    Yes, running 5.10 and was getting the same results on 5.9.

    1) zoom level currently is not an issue. Are you online (cell/WiFi)? Or are you offline? If so is this on map imagery you prepped and saved down past 8 zoom? What map type?
    I have tried this both online and offline. Same results, if the zoom level is greater then 7, the maps will disappear.

    Posted the screen recording to

    When I turn the iPad offline, I have downloaded maps in that area.

    I am subscribed to the Advanced Subscription.

    Let me know if you have additional questions or need a more specific screen recording.
  • Damian_offthegridDamian_offthegrid Posts: 638Administrator, Moderator admin
    On the map imagery... looking at your video. I see you are not on WiFi nor have any cell service...less than a bar. Assuming you are trying to view saved imagery tiles in this video? Can you send a screenshot of your saved tile layout in the map download manager for that map type?
  • Damian_offthegridDamian_offthegrid Posts: 638Administrator, Moderator admin
    Also you are running iOS 13 beta which is not yet supported or finalized by Apple. We should be able to see your crash logs though as a Beta tester. It is hard to say what’s going on though until Apple gets closer to releasing 13.
  • Damian_offthegridDamian_offthegrid Posts: 638Administrator, Moderator admin
    Thank you for this feedback.

    As I’m reading all the current known issues with iOS13 we would recommend refraining from utilizing it other than for general testing. Once we get closer to the official fall release we will start meeting them in the middle with what is currently a bug on their end and possibly ours.
  • OneFast440OneFast440 Posts: 7Member
    Damian,

    In the video I am on WiFi at the beginning, half way through the video I turn off all wireless signals to show you it does not work offline either.

    Here is the requested photo of my tile downloads. I have 745 tiles saved.
    https://imgur.com/VJV2ryU

    As mentioned in my original post, I fully understand that iOS 13 is a beta and that there are bugs on Apple's end. Just trying to assist and give you guys a head start if it's on your end.

    I use my equipment for development purposes as well and it would be nice to have it working if it was on your end.

    I am local to your office. If you want me to swing by and allow you to debug my device. I thought it was odd that you said you couldn't reproduce it on your dev devices.

    Thanks again. Appreciate the great app.
  • Damian_offthegridDamian_offthegrid Posts: 638Administrator, Moderator admin
    Appreciate the feedback and in fact with our new work to pull LEADNAV in app subscriptions offline and into our own hands we would be glad to give you a free subscription to Pro Pack once it’s ready.

    We are currently wrapping up the next release and working through some current deep bugs that have been around for awhile.

    We will probably start hitting iOS 13 in the next few weeks.

    If you are local maybe we can schedule a day to stop in to take a look.
  • Damian_offthegridDamian_offthegrid Posts: 638Administrator, Moderator admin
    Ok wow... we see the issue!

    745 tiles is ALOT of tiles even for Pro pack. This is not from iOS13, as we’ve seen this before.

    Advanced is not made to save and store that many micro tiles. You are confusing and overloading the system.

    With Pro you are able to perform save along Route or save 1 gig individual tiles. So you can save much larger areas in less tiles.

    You are stacking so many micro tiles with advanced it can’t handle it.

    Even with Pro this again would me a lot of area.

    In the future we are looking to measure this usage and possibly only bill folks per tile limit.

    When you are looking to store this much imagery there are much better outside ways to build these files as well.

    We will put you on the beta program and push you Pro pack to try so you can see the difference.

    Please send your info and email address to [email protected]
  • Damian_offthegridDamian_offthegrid Posts: 638Administrator, Moderator admin
    Also to be clear...our primary office is now in Chesapeake Virginia... just noticing your tiles are in Phoenix so assuming you are local to our old office there..?
  • OneFast440OneFast440 Posts: 7Member
    I sent a couple of emails to the address you provided. No response...
  • phaskphask Posts: 11Member
    edited July 25
    I am also having issues with iOS13 and have a lot of tiles as I save map data for at least 10-15 routes I am running year round. My iPhone XS Max and iPad Pro 9.7" are both on iOS 13 Public Beta 3, and see the issue. The iPhone is on wifi and has no tiles saved, whereas the iPad has 200+ tiles saved and sees the problem. I would have avoided updating but being where I work I needed the betas to test a lot of apps

    Whereas my iPad Mini 4 does not have the issue (still on iOS 12), and has well over 300 tiles saved.

    @Damian_offthegrid can I get in on helping with the beta testing as well?
  • Damian_offthegridDamian_offthegrid Posts: 638Administrator, Moderator admin
    phask said:

    I am also having issues with iOS13 and have a lot of tiles as I save map data for at least 10-15 routes I am running year round. My iPhone XS Max and iPad Pro 9.7" are both on iOS 13 Public Beta 3, and see the issue. The iPhone is on wifi and has no tiles saved, whereas the iPad has 200+ tiles saved and sees the problem. I would have avoided updating but being where I work I needed the betas to test a lot of apps

    Whereas my iPad Mini 4 does not have the issue (still on iOS 12), and has well over 300 tiles saved.

    @Damian_offthegrid can I get in on helping with the beta testing as well?

    Thank you for the input as we are now aware of the bug with the iOS13 Beta and are looking into it. As testers you probably know how much Apple is shaking things up with both OS Catalina and this iOS13. They have a lot of their own bugs to work through before we can take a look. We are currently working heavily on big picture coding but hopefully we will have some time to figure something out with what they are doing prior to the official release of iOS13 if they don't fix it. A ticket was sent to Apple and hopefully they fix whatever they are doing with mapping so we don't need to waste time patching the issue.
  • phaskphask Posts: 11Member
    One other issue, when attempting to load GPX files some OneDrive, Safari, Outlook or really any other application, LeadNav is not in the list of apps to send files to. I have Gaia installed as well and it is still listed. I tried offloading the app and reinstalling, no go. Uninstalled/reinstalled on my iPhone, still no change there.

    Wouldn't mind helping with the Beta work as I have to run beta OSes on my devices for work as is.
  • Damian_offthegridDamian_offthegrid Posts: 638Administrator, Moderator admin
    phask said:

    One other issue, when attempting to load GPX files some OneDrive, Safari, Outlook or really any other application, LeadNav is not in the list of apps to send files to. I have Gaia installed as well and it is still listed. I tried offloading the app and reinstalling, no go. Uninstalled/reinstalled on my iPhone, still no change there.

    Wouldn't mind helping with the Beta work as I have to run beta OSes on my devices for work as is.

    Assuming this is with iOS 13 Beta?
  • phaskphask Posts: 11Member
    Correct, this is with the iOS 13 Public Beta 3. Also can repro with the iPadOS 13 Public Beta 3.
  • Damian_offthegridDamian_offthegrid Posts: 638Administrator, Moderator admin
    phask said:

    Correct, this is with the iOS 13 Public Beta 3. Also can repro with the iPadOS 13 Public Beta 3.

    Not sure on that one but after doing some Airdrop tests and opening from Apples File app... both offered the option to export/import into LEADNAV. Will test further when we start focusing on iOS13.

    Thank you
  • OneFast440OneFast440 Posts: 7Member
    Damian - I'm happy to report that in the latest iOS Beta 13.1 (released today) and your latest update 5.14 both the maps and sharing issues have been resolved! Thank you! I have not received a response from the emails I sent you though. Let me know how I can continue to help.
  • Damian_offthegridDamian_offthegrid Posts: 638Administrator, Moderator admin
    Yes we put a temp Apple bug patch out on 5.14...so hopefully it’s not needed by time Apple fixes it. Also the sharing is all on their end. They still have a lot to work out till us developers get in there n take a look
Sign In or Register to comment.

Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!